Print Page | Close Window

Clutch Fluid

Printed From: rsvr.net Forums
Category: Tuono
Forum Name: General & Technical
Forum Description: Everything and anything to do with the Terrific Tuono... the ultimate Streetfigher!
URL: http://www.rsvr.net/forum_posts.asp?TID=26888
Printed Date: 23 Jul 2018 at 18:18
Software Version: Web Wiz Forums 12.00 - http://www.webwizforums.com


Topic: Clutch Fluid
Posted By: Roger Ramjet
Subject: Clutch Fluid
Date Posted: 23 Jun 2018 at 21:41
Hi folks - my 2005 Gen 1's clutch lever has gone 'soft' after sitting up for a few weeks and will not engage - as the fluid reservoir appears empty, I have to assume as a stage #1 that this could be the issue (as all OK when it went onto the paddock stand). Trip to Halfords tomorrow - any recommendations as to what fluid should be purchased please?
 



Replies:
Posted By: budd
Date Posted: 23 Jun 2018 at 22:01
any DOT 4 brake fluid is fine nothing special required, although I think it wise to find out where the original fluid went before adding more, it's a sealed system (or at least it should be !!) chances are you have a leak so any new fluid will likley go the way of the old.


Posted By: Blender81
Date Posted: 23 Jun 2018 at 23:10
its most likely the slave cylinder seal has gone, if the side stand hinge is covered thats the cause, replace the seal then fluid Thumbs Up


Posted By: snowman
Date Posted: 24 Jun 2018 at 12:30
my fluid disappeared too a few yrs ago, it was the slave , phoned A/P for a upgrade slave ( £90) they said not needed just sent me the new seal, 1/2 hr to an hour  to change etc, still good .



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.00 - http://www.webwizforums.com
Copyright ©2001-2018 Web Wiz Ltd. - https://www.webwiz.net