rsvr.net Forums Homepage
Forum Home Forum Home > General Chat > Technical info
  New Posts New Posts RSS Feed - Bike ticks when key is turned
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Bike ticks when key is turned

 Post Reply Post Reply
Author
Message
Kraysisters1 View Drop Down
Moto3 racer
Moto3 racer
Avatar

Joined: 04 Feb 2014
Location: Manchester
Status: Offline
Points: 98
Post Options Post Options   Thanks (0) Thanks(0)   Quote Kraysisters1 Quote  Post ReplyReply Direct Link To This Post Topic: Bike ticks when key is turned
    Posted: 11 May 2020 at 20:43
Can anyone tell me what the part is just at the rear of the battery. I thought it was a starter relay but on buying a new one it doesnt fit. 
My rsv wont start, when you turn the key it clicks. Battery is full charged and this small part has something rattling inside, which I assume is bad news. Have taken a picture but cant seem to add it to this pos . 
Thanks in advance. 
D Hatton
Back to Top
wigginsjp View Drop Down
Premium Member
Premium Member
Avatar

Joined: 11 Feb 2008
Location: calne
Status: Offline
Points: 2087
Post Options Post Options   Thanks (0) Thanks(0)   Quote wigginsjp Quote  Post ReplyReply Direct Link To This Post Posted: 11 May 2020 at 20:46
Hi 

Immediately behind the battery by the fuses? Not the tip over switch by chance? Make sure it is the right way up. 

A clicking however is more likely the solenoid. Is yours a genuine 150amp one? Make sure all the battery cables are good and that the one to the starter is not rotten too 

The tip over switch should rattle is shaken. Pop it off and look at it. Bad apple may have one or Paul W is a spares pile. Possibly mixdrive too 
www.apriliaperformance.co.uk
www.apriliaforum.co.uk
www.apriliaownersclub.co.uk
www.apworkshops.co.uk
Back to Top
Kraysisters1 View Drop Down
Moto3 racer
Moto3 racer
Avatar

Joined: 04 Feb 2014
Location: Manchester
Status: Offline
Points: 98
Post Options Post Options   Thanks (0) Thanks(0)   Quote Kraysisters1 Quote  Post ReplyReply Direct Link To This Post Posted: 11 May 2020 at 20:46
https://s.amsu.ng/TQaOOyYlXmNN



Dont know of this will work but hopefully it's the picture I'm talking about. 
D Hatton
Back to Top
wigginsjp View Drop Down
Premium Member
Premium Member
Avatar

Joined: 11 Feb 2008
Location: calne
Status: Offline
Points: 2087
Post Options Post Options   Thanks (0) Thanks(0)   Quote wigginsjp Quote  Post ReplyReply Direct Link To This Post Posted: 11 May 2020 at 20:48
That’s the tip over switch. 

Make sure it’s the correct way up or it won’t start thinking the bike is upside down 
www.apriliaperformance.co.uk
www.apriliaforum.co.uk
www.apriliaownersclub.co.uk
www.apworkshops.co.uk
Back to Top
Kraysisters1 View Drop Down
Moto3 racer
Moto3 racer
Avatar

Joined: 04 Feb 2014
Location: Manchester
Status: Offline
Points: 98
Post Options Post Options   Thanks (0) Thanks(0)   Quote Kraysisters1 Quote  Post ReplyReply Direct Link To This Post Posted: 11 May 2020 at 20:52
Well that's answered what that is lol. It was the correct way up, issue still the same. Think it will be a strip down when I get a day off 
D Hatton
Back to Top
Ice-mille View Drop Down
Moto GP Alien
Moto GP Alien
Avatar

Joined: 19 Aug 2016
Location: Iceland
Status: Offline
Points: 570
Post Options Post Options   Thanks (0) Thanks(0)   Quote Ice-mille Quote  Post ReplyReply Direct Link To This Post Posted: 12 May 2020 at 23:01
Bad Relay?
Shake'n bake
Back to Top
Kraysisters1 View Drop Down
Moto3 racer
Moto3 racer
Avatar

Joined: 04 Feb 2014
Location: Manchester
Status: Offline
Points: 98
Post Options Post Options   Thanks (0) Thanks(0)   Quote Kraysisters1 Quote  Post ReplyReply Direct Link To This Post Posted: 12 May 2020 at 23:24
Thanks, just waiting for a day off so I can get things sorted. 
D Hatton
Back to Top
badapple View Drop Down
Premium Member
Premium Member
Avatar

Joined: 03 Nov 2014
Location: Norwich United Kingdom
Status: Offline
Points: 4354
Post Options Post Options   Thanks (0) Thanks(0)   Quote badapple Quote  Post ReplyReply Direct Link To This Post Posted: 12 May 2020 at 23:32
Hope you can source the problem, probably got a spare of any dodgy part
I started out with nothing and I've still got most of it left
Back to Top
Kraysisters1 View Drop Down
Moto3 racer
Moto3 racer
Avatar

Joined: 04 Feb 2014
Location: Manchester
Status: Offline
Points: 98
Post Options Post Options   Thanks (0) Thanks(0)   Quote Kraysisters1 Quote  Post ReplyReply Direct Link To This Post Posted: 20 May 2020 at 21:46
Well one starter relay and battery later and the beast is trying to take my licence again. Thanks for the help guys. 
D Hatton
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.03
Copyright ©2001-2019 Web Wiz Ltd.

This page was generated in 0.047 seconds.